User talk:Base

From Wikitech
Jump to navigation Jump to search

Welcome to Tool Labs

Hello Base, welcome to the Tool Labs project! Your request for access was processed and you should be able to login now via ssh at tools-login.wmflabs.org. To get started, check the help page and the migrating from the Toolserver page. You can also ask in our irc channel at #wikimedia-labs connect or send an e-mail to our mailing list labs-l@lists.wikimedia.org - thank you, and have fun using labs! petrb (talk) 18:36, 1 June 2013 (UTC)[reply]

Basebot stop

I was forced to stop basebot as it was spamming error to the admins that looked like https://phabricator.wikimedia.org/P6151. After dozens and no real idea of the failure I had to stop it and comment out the crons. Rush (talk) 21:40, 18 October 2017 (UTC)[reply]

Rush, Oh. Well, it has nothing to do with jobs running from cron so I have uncommented it. I had problem starting webservice I had HTTP 502 when it was on, but I thought it was caused by me running a heavyweight PHP script, now I see from the log you linked that it is probably because I have archived error.log by renaming it and moving to another folder and recreating a new one, I have probably not given permissions webservice needs to work with it, I will look into it. Thanks for poking! --Base (talk) 23:14, 18 October 2017 (UTC)[reply]
Hm, though both the old log file and the new are -rw-r--r--, I am not really sure where the problem is. --Base (talk) 23:18, 18 October 2017 (UTC)[reply]
Oh, but the old one is owned by the group. I will set write to the group then, as I chown does not seem to work. --Base (talk) 23:22, 18 October 2017 (UTC)[reply]
Ah, I see it was owned by the user, not the tool, now I have taken it and chowned to group. Hopefully this should be it. I will try to restart webservice now. --Base (talk) 23:35, 18 October 2017 (UTC)[reply]
Yay, it works. Linux is too harsh for summerWindows childrenusers like myself. --Base (talk) 23:36, 18 October 2017 (UTC)[reply]