User talk:Legoktm/toolforge library

From Wikitech
Jump to navigation Jump to search


Thank you, this is very helpful. --Nemo 05:45, 27 August 2017 (UTC)[reply]

How to use this on toolforge (python3.5)?

It states this module "Requires: Python >=3.4" and we have 3.5 on toolforge, unfortunately it has pymysql as a dependency, which "Requires: Python >=3.6"... so toolforge seems to be unusable on toolforge:-) What gives? --dschwen (talk) 23:36, 8 April 2021 (UTC)[reply]

dschwen: Not sure if it's helpful at this point, but I was able to get this to work by manually running pip install PyMySQL==0.10.1 to get the last version that supported Python 3.5 before installing this library (in a virtualenv). Vahurzpu (talk) 22:49, 10 May 2021 (UTC)[reply]